Follow the prerequisites and steps below to integrate the SDKs with your app.

Prerequisites

These are the frameworks you must have before starting to use OCRLabs SDKs:

  • Android Studio or an equivalent IDE for Android development.
  • Minimum Android SDK version: 8.
  • The latest SDK files (version 3.6.1503.2022) and Code Sample App from your Account Manager

Each framework is for a specific use case:

  • orbitmedicare-release.Aar is used for Australian medicare cards.
  • orbitsdk-release.Aar is used for all other identification, such as driver's licenses.
  • orbitmrz-release.Aar is used for passports.

SDK and Sample Code Installation

First, download the SDK which contains the .aar files from your Account Manager. After downloading the SDKs and the sample codes, follow these steps below:

Step 1: Copy AAR Files

Copy all the aar SDK library files into the SDK you downloaded.

600600

Copy the arr files

Step 2: Paste AAR Files

Open your Android project, then paste files the app/libs folder.

295295

Paste the arr files

Step 3: Link Orbit AAR Libraries

Link the library using a dependency statement below in your app build.gradle file.

Gradle will build your dependencies automatically.

dependencies {
        implementation files('libs/orbitmrz-release.aar')
        implementation files('libs/orbitsdk-release.aar')
        implementation files('libs/orbitmedicare-release.aar')
}
600600

Paste the files

Step 4: Import the OrbitSDK Classes

To import the OrbitSDK class, from your java code, introduce the following import statement:

import com.ocrlabs.orbitsdk.OrbitSDK;
import com.ocrlabs.orbit.mrz.OrbitMrzSDK;
import com.ocrlabs.orbitmedicare.OrbitMedicareSDK;
600600

Paste the files

💬 We're here to help!

If you encounter an issue, a bug, or require assistance, please contact our support page here to find the solution. Don't forget to provide any important information on the issue.